http://nettips.ru

Подключение cisco 800 к интернету byfly по PPPoE

На главную Cisco Systems VoIP маршрутизатор Беларусь Asterisk коммутатор Nateks Alcatel MTS Gigaset Velcom ZTE Grandstream Android Huawei админы шутят о сайте Zelax Allied Telesis D-Link Arduino Штрихкоды HP
Телефонные номера доступа sip операторов Телефонные коды городов и стран мира.

Рейтинг статьи: 2.792/5 Рейтинг 2.79 из 5Рейтинг 2.79 из 5Рейтинг 2.79 из 5Рейтинг 2.79 из 5Рейтинг 2.79 из 5 (24 голосов).

Когда интернет используют много устройств и пользователей возникает множество вопросов совместного существования. Со временем понимаешь, что обычного модема ZTE не хватает. Решил поискать варианты с cisco.

Спонсор этой страницы: купить перчатки хб

Выбор оборудования

Самое простое найти маршрутизатор cisco минимум с двумя ethernet портами. Например cisco 800 серии модели 831, 871. Если найдете 1800 серии, тоже неплохо. Купить можно на ebay.

Мне досталась cisco 831, поэтому статья именно про неё.

Первичный запуск.

После покупки б.у. оборудования можно попасть либо на отсутствие прошивки, либо на отсутствие пароля.

Запустив программу Putty (http://www.putty.org) и подключившись консольным кабелем ждем приглашение.

Если видим rommon 1 >, необходимо заливать прошивку (IOS)
Если видим Password :Сбрасываем настройки

Все настройки приведены для IOS c831-k9o3sy6-mz.124-5a.bin

Начальная настройка сети

Маршрутизатор cisco 831 в зависимости от прошивки имеет 2-3 порта для маршрутизации E0 и E1 (доп. E2) и 4-х портовый коммутатор, привязанный к порту E0

Порт E1 стоит обособлено. В него и будем подключать интернет отданный телекомом. Это может бить через модем ZTE (Промсвязь) или через оптический конвертер.

Так как IP адрес ADSL модемов по умолчанию обычно 192.168.1.1, то прописываем на E1 эту же подсеть.

interface Ethernet1
  ip address 192.168.1.2 255.255.255.0
  no shutdown

Компьютеры будут подключены в порты FE1- FE4 через порт маршрутизации E0, поэтому настраиваем порт E0 под локальную сеть

interface Ethernet0
  ip address 192.168.2.1 255.255.255.0
  no shutdown

Поднимаем DHCP сервер.

ip dhcp excluded-address 192.168.14.0 192.168.14.10
!
ip dhcp pool home
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   option 42 ip 192.168.2.1
   dns-server 8.8.8.8 208.67.222.222
   lease 7

DNS сервера выбраны от google и от opendns. Кому нравятся белтелекомовские, можете вписать 82.209.200.16 и 17

Настраиваем время. (часовой пояс для РБ 3 без перехода. NTP сервер 3.by.pool.ntp.org

clock timezone FET 3
ntp server 86.57.251.8

Включние PPPoE

Создаем соединение с ByFly по pppoe и поднимаем NAT.

interface E1
  pppoe enable
  pppoe-client dial-pool-number 1

interface Dialer1
   description byfly
   bandwidth 2048
   ip address negotiated
   ip mtu 1492
   ip nat outside
   ip virtual-reassembly
   encapsulation ppp
   no ip mroute-cache
   dialer pool 1
   dialer-group 1
   ppp authentication chap callin
   ppp chap hostname 2100xxxxxxxxxx@beltel.by
   ppp chap password пароль

interface E0
   ip nat inside

ip route 0.0.0.0 0.0.0.0 Dialer1
access-list 1 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip permit
ip nat inside source list 1 interface Dialer1 overload

Защита от доступа к маршрутизатору

Для примера перекрываем порты telnet и http, чтобы на наш маршрутизатор не могли попасть снаружи.

Вообще HTTP на cisco лучше выключить. Меньше соблазна детям покопаться.

И не забываем прописать пароли на доступ по telnet и на enable

access-list 100 deny tcp any any eq 23
access-list 100 deny tcp any any eq 80
access-list 100 permit ip any any
interface Dialer1
   ip access-group 100 in

no ip http server
no ip http secure-server

line vty 0 4
   password пароль_на_telnet
   login

enable secret пароль_на_enable

В общем первичная настройка сделана, теперь приступаем к дополнительным фичам.

Использование WiFi от модема ZTE (Промсвязь)

При настройках по умолчанию в модем включен в режиме моста и на LAN включен протокол RIP

Воспользоватся ситуацией с RIP и передадим модему информацию и нашей сети 192.168.2.0 и о доступе в Интернет.

router rip
   version 2
   network 0.0.0.0

После чего получаем доступ к модему, настраиваем пароль на WiFi и проверяем настройки DHCP на модеме (указываем пользовательские DNS сервера).
В случае, если модем не виден из сети возможно он не получил по RIP список сетей. Заходим на модем, переключив кабель, и в секции Interface Setup / Lan / Direction указываем Both.

В секции Advanced Setup / Routing смотрим, что появились маршруты на нашу cisco.

После чего добавляем правила и интерфейс E1 в NAT.

access-list 1 permit 192.168.1.0 0.0.0.255
interface E1
   ip nat inside

Передача портов из внешнего интерфейса на локальные компьютеры для доступа из интернет к локальным сервисам.

Написал что-то, аж сам запутался.

В общем например надо открыть порты torrent или организовать доступ из интернета по radmin, ftp, http, Fidonet, камеры наблюдения в локальной сети. Надеюсь мысль.

Если у Вас качает torrent, необходимо указать, куда маршрутизатор будет отсылать пакеты предназначенные torrent.

Для этого необходимо иметь не меняющийся локальный IP адрес на компьютере. Два варианта: Прописать статику или настроить DHCP/

ip dhcp pool pc_1
   host 192.168.2.200 255.255.255.0
   hardware-address 001e.8ee7.aaaa

И указать для torrent TCP и UDP порты (смотрим в настройках torrent. например 11111)

ip nat inside source static tcp 192.168.2.200 11111 interface Dialer1 11111
ip nat inside source static udp 192.168.2.200 11111 interface Dialer1 11111

Соответственно, если Вы подымаете на своем компе ftp сервер и хотите иметь к нему доступ снаружи, то настройки выглядят так:

ip nat inside source static tcp 192.168.2.200 20 interface Dialer1 20
ip nat inside source static udp 192.168.2.200 21 interface Dialer1 21

Использование DDNS

Если вы решили поднять ftp, то возникнет проблема. Как вы найдете себя из интернета, ведь внешний адрес вы получаете динамически, и он меняется при каждом пересоединении.

Один вариант - купить статический IP, второй использовать ddns, то есть сообщить dns серверам, что за определенным именем зарегистрирован определенный IP адрес.

Я использовал dyndns.dk. После регистрации получаешь имя типа vasya.dyndns.dk

Там же предлагают ссылку для сопоставления своего имени и адреса

Можно запрос этой ссылки поручить выполнять cisco по расписанию.

kron policy-list DDNS
  cli copy http://dyndns.dk/opdat.php?name=vasysa&domain=dyndns.dk&pw=какой_то_табор_буковок&silent=1 null:

kron occurrence ddns in 1:00 recurring
  policy-list DDNS

Таким образом маршрутизатор будет каждый час напоминать DNS серверам о своем адресе.

Минус только в том, что после пересоединения и смены IP адреса должно пройти время (до 2-х часов) для распространения информации по DNS серверам, поэтому, если у Вас на этом завязан бизнес, купите IP адрес.

Читайте далее:
Подключение cisco 800 к интернету byfly по PPPoE часть 2 QOS.
Подключение cisco 800 к интернету byfly по PPPoE часть 3. Родительский контроль

Cisco Systems модем маршрутизатор ZTE Беларусь

Пожалуйста, оцените и ВЫ эту статью:

Комментарии к статье:

  • 2015-01-15 02:35:54, Гость :

    Не мешало бы добавить пару строк в конфиг. Выявлены в долгой борьбе с Cisco851 :)
    no spanning-tree vlan 1
    (если локалка тегированная)
    ip nat inside source static tcp 10.12.2.17 22 87.251.111.111 11 extendable
    (Часто встечающийся глюк серии 800, -нет доступа извне по 22 п)


Ваши отзывы и предложения по работе сайта направляйте на форму обратной связи.

Яндекс.Метрика