http://nettips.ru

Подключение cisco 800 к интернету byfly по PPPoE часть 2 QOS

На главную Cisco Systems VoIP маршрутизатор Беларусь Asterisk коммутатор Nateks Alcatel MTS Gigaset Velcom ZTE Grandstream Android Huawei админы шутят о сайте Zelax Allied Telesis D-Link Arduino Штрихкоды HP
Телефонные номера доступа sip операторов Телефонные коды городов и стран мира.

Рейтинг статьи: 2.000/5 Рейтинг 2.00 из 5Рейтинг 2.00 из 5Рейтинг 2.00 из 5Рейтинг 2.00 из 5Рейтинг 2.00 из 5 (5 голосов).

Продолжаем настройке маршрутизатора cisco 831. Настраиваем приоритеты.

Спонсор этой страницы:

Начало описано в статье Подключение cisco 800 к интернету byfly по PPPoE .

Все настройки приведены для IOS c831-k9o3sy6-mz.124-5a.bin

Описание приоритетов.

Попытаюсь в общих чертах описать задумку.

  • Голосовой трафик должен ходить без замещений.
  • Торентов и FTP не должна мешать ни голосу ни сетевому серфингу.
  • Должна учитываться полоса пропускания ByFly согласно тарифного плана.
  • Трафик с Белорусских IP адресов ограничен физическим состоянием линии.

Описываем 3 типа трафика. Голос, сайты, почта. И четвертый - все остальное. Для этого испотзуем систему распознавания трафика nbar.

class-map match-any voip
   match protocol sip
   match protocol h323
   match protocol rtp
   match dscp ef

class-map match-any www
   match protocol http
   match protocol secure-http
   match dscp af21

class-map match-any email
   match protocol pop3
   match protocol smtp
   match protocol secure-pop3
   match protocol secure-nntp
   match protocol secure-imap

Описываем потоки в локальной сети, сети Республики Беларусь и сети интернета и создаем соответствующие классы.

access-list 192 permit ip 192.168.0.0 0.0.255.255 192.168.0.0 0.0.255.255

class-map match-any local
   match access-group 192

access-list 175 permit ip 37.44.64.0 0.0.15.255 any
access-list 175 permit ip 37.44.80.0 0.0.15.255 any
access-list 175 permit ip 37.44.96.0 0.0.31.255 any
access-list 175 permit ip 37.45.0.0 0.0.63.255 any
access-list 175 permit ip 37.45.64.0 0.0.63.255 any
access-list 175 permit ip 37.45.128.0 0.0.63.255 any
access-list 175 permit ip 37.212.0.0 0.3.255.255 any
access-list 175 permit ip 82.209.192.0 0.0.63.255 any
access-list 175 permit ip 86.57.128.0 0.0.127.255 any
access-list 175 permit ip 93.84.0.0 0.1.255.255 any
access-list 175 permit ip 178.120.0.0 0.7.255.255 any
access-list 175 permit ip 193.232.248.0 0.0.3.255 any
access-list 175 permit ip 194.226.120.0 0.0.3.255 any
access-list 175 permit ip 194.226.124.0 0.0.1.255 any
access-list 175 permit ip 194.158.192.0 0.0.1.255 any
access-list 175 permit ip 194.158.196.0 0.0.3.255 any
access-list 175 permit ip 194.158.202.0 0.0.0.255 any
access-list 175 permit ip 194.158.204.0 0.0.3.255 any
access-list 175 permit ip 194.158.208.0 0.0.1.255 any
access-list 175 permit ip 194.158.210.0 0.0.0.255 any
access-list 175 permit ip 194.158.212.0 0.0.3.255 any
access-list 175 permit ip 194.158.216.0 0.0.7.255 any
access-list 175 permit ip 195.137.180.0 0.0.0.255 any

class-map match-any belarus
   match access-group 175

access-list 199 permit ip any 192.168.0.0 0.0.255.255

class-map match-any internet
   match access-group 199

Настройка приоритетов входящего трафика.

Так как очереди работают только на исходящем трафике, то описываем правила на локальных интерфейсах E0 и E1

Заодно его и промаркируем. Маркировку используем пр исходящем трафике. Может быть byfly выполнит обещание ввести у себя qos.

policy-map shape_procent
   class voip
     priority percent 20
     set dscp ef
   class www
     bandwidth percent 30
     set dscp af21
   class email
     bandwidth percent 10
   class class-default
     fair-queue

Связываем вместе классы трафика, сети и полосы пропускания

policy-map internet_in0
  class local
     shape average 10000000
     service-policy shape_procent
  class belarus
     shape average 5600000
     service-policy shape_procent
  class internet
     shape average 2000000
     service-policy shape_procent

В этом примере локальный трафик - 10 мбит/с, трафик из РБ (необходимо посмотреть скорость физического соединения на модеме) 5,6 мбит/с, и тарифный план на 2 мбит/с

И теперь привязываем policy-map internet_in0 к локальному интерфейсу E0.

interface Ethernet0
   service-policy output internet_in0

В случае, если мы используем модем ZTE в качестве точки доступа WiFi через E1, то добавляем настройки и для E1 с учетом того, что через E1 у нас работает соединение PPPoE

policy-map internet_in1
  class local
    shape average 4000000
     service-policy shape_procent
  class belarus
    shape average 3000000
     service-policy shape_procent
  class internet
    shape average 2000000
     service-policy shape_procent

interface Ethernet1
  service-policy output internet_in1

Настройка приоритетов исходящего трафика.

Исходящий трафик тоже желательно проверить, чтобы torrent не мешал http запросам и голосу.


interface Dialer1
  bandwich 512
  service-policy output shape_procent

Увы cisco 831 на dialer не поддерживает policy-map с shape. При попытка повесить на интерфейс dialer1 policy-map internet_in0 получаем ошибку:
GTS : Not supported on this interface
поэтому разделить трафик к белорусским сетям и остальной трафик нет возможности, хотя, возможно я не придумал как, поэтому буду рад выслушать рекомендации, которые проверю на железяке.

Следует учесть, что если одновременно начнут качать и со стороны E0 и со стороны E1 возможны пропуски трафика, поэтому, если вы активно используете обе сети, уменьшите в соответствующих policy-map полосы пропускания в классе internet, так чтобы в сумме они давали общую полосу пропускания.

Читайте далее:
Подключение cisco 800 к интернету byfly по PPPoE часть 3 Родительский контроль

Cisco Systems модем коммутатор маршрутизатор Беларусь

Пожалуйста, оцените и ВЫ эту статью:

Комментариев нет. Снаньте первым!


Ваши отзывы и предложения по работе сайта направляйте на форму обратной связи.

Яндекс.Метрика