http://nettips.ru

Организация резервного канала на cisco

На главную Cisco Systems VoIP маршрутизатор Беларусь Asterisk коммутатор Nateks Alcatel MTS Gigaset Velcom ZTE Grandstream Android Huawei админы шутят о сайте Zelax Allied Telesis D-Link Arduino Штрихкоды HP
Телефонные номера доступа sip операторов Телефонные коды городов и стран мира.

Рейтинг статьи: 2.517/5 Рейтинг 2.52 из 5Рейтинг 2.52 из 5Рейтинг 2.52 из 5Рейтинг 2.52 из 5Рейтинг 2.52 из 5 (29 голосов).

Хотели в нескольких удаленных офисах установить по второму маршрутизатору cisco, но денег выделили на один на всех. Cisco 2811. Решил сконфигурировать его так, что бы без изменения конфигурации привезли, включили, заработал.

Спонсор этой страницы:

Дано:

  • На удаленных офисах старенькие рутеры Cisco 1721 + комутатор Cisco 2950.
  • Канал на центральный офис в ADSL-VPN.
  • От удаленного офиса до центрального построены тунели
  • Cеть офиса и сеть ADSL-VPN в разных Vlan.
  • IP адреса на некоторых устройствах в удаленных офисах статические и не могут быть изменены
Цель:
  • Новый cisco 2811 должен быть быть настроен так, что случае выхода из строя старого маршрутизатора новый мог привезти например водитель, включть и ... все заработало
  • Основной и резервный маршрутизаторы не должны мешать друг другу

Версия IOS на маршрутизаторе

Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(24)T2, RELEASE SOFTWARE (fc2)
c2800nm-advipservicesk9-mz.124-24.T2.bin

Подготовка основного маршрутизатора на оффисе.

Для будущей связки двух маршрутизаторов используем протокол HSRP

Настройки офиса 2

interface FastEthernet0

no ip address
speed auto


interface FastEthernet0.1

description office 2
encapsulation dot1Q 1 native
ip address 192.168.2.2 255.255.255.0
standby 2 ip 192.168.2.1
standby 2 priority 50
standby 2 preempt<


interface FastEthernet0.2

description VPN to Center
encapsulation dot1Q 2
ip address 10.1.2.2 255.255.255.0


interface Tunnel2

description VPN to Center
ip address 10.2.2.2 255.255.255.252
keepalive 10 3
tunnel source FastEthernet0.246
tunnel destination 10.1.1.1


ip route 10.1.1.0 255.255.255.248 F0.2 10.1.2.5
ip route 0.0.0.0 0.0.0.0 Tunnel2 10.2.2.5

10.1.1.0/29 - сеть центрального офиса от провайдера
10.1.2.0/29 - сеть офиса N2 от провайдера
10.2.2.0/30 - сеть офиса N2 для тунельного интерфейса
192.168.2.0/24 - сеть офиса N2
192.168.2.1 - Шлюз по умолчанию для офисных пользователей
192.168.3.0/24 - сеть офиса N3
192.168.4.0/24 - сеть офиса N4
Остальное по аналогии.

Подготовка резервного маршрутизатора

Описываем локальные подсети офисов как secondary

interface FastEthernet0/0.1

description Office All
encapsulation dot1Q 1 native
ip address 192.168.255.1 255.255.255.0
ip address 192.168.2.3 255.255.255.0 secondary
ip address 192.168.3.3 255.255.255.0 secondary
ip address 192.168.4.3 255.255.255.0 secondary
standby 2 ip 192.168.2.1
standby 2 priority 40
standby 2 preempt
standby 3 ip 192.168.3.1
standby 3 priority 40
standby 3 preempt
standby 4 ip 192.168.4.1
standby 4 priority 40
standby 4 preempt

Локальные IP адреса офисов описаны как Secondary. Подсеть 192.168.255.0 для локальных адресов без статики. Если небходимо, можно повесить для этих пользователей DHCP сервер

ip dhcp pool Backup

network 192.168.255.0 255.255.255.0
default-router 192.168.255.1
dns-server 8.8.8.8 8.8.4.4

Описываем подсети офисов от провайдеров

interface FastEthernet0.2

description VPN to Center
encapsulation dot1Q 2
ip address 10.1.2.3 255.255.255.0
ip address 10.1.3.3 255.255.255.0 secondary
ip address 10.1.4.3 255.255.255.0 secondary

Теперь необходимо проложить маршрут к центральному офису через сеть провайдера. Для этого необходимо определить, какой IP доступен

track 2 ip sla 2 reachability
track 3 ip sla 3 reachability
track 4 ip sla 4 reachability

ip sla 2
  icmp-jitter 10.1.2.5 source-ip 10.1.2.3 num-packets 3
ip sla schedule 2 life forever start-time now

ip sla 3
  icmp-jitter 10.1.3.5 source-ip 10.1.3.3 num-packets 3
ip sla schedule 3 life forever start-time now

ip sla 4
  icmp-jitter 10.1.4.5 source-ip 10.1.4.3 num-packets 3
ip sla schedule 3 life forever start-time now

После определения, какой IP доступен прописываем статический маршрут

ip route 10.1.1.0 255.255.255.248 F0.2 10.1.2.5 track 2
ip route 10.1.1.0 255.255.255.248 F0.2 10.1.3.5 track 3
ip route 10.1.1.0 255.255.255.248 F0.2 10.1.4.5 track 4

Таким образом при включении на уталенном офисе, не важно 2, 3 или 4, маршрутизатор увидит сеть провайдера, и проложит машрут для тунеля

Готовим тунели по количеству резервируемых офисов

interface Tunnel1002

description Backup VPN office 2 to Center
ip address 10.3.2.2 255.255.255.0
keepalive 10 3
tunnel source 10.1.2.3
tunnel destination 10.1.1.1

interface Tunnel1003

description Backup VPN office 3 to Center
ip address 10.3.3.2 255.255.255.0
keepalive 10 3
tunnel source 10.1.3.3
tunnel destination 10.1.1.1

interface Tunnel1004

description Backup VPN office 3 to Center
ip address 10.3.4.2 255.255.255.0
keepalive 10 3
tunnel source 10.1.4.3
tunnel destination 10.1.1.1

Ну и соответственно необходимы маршруты по умолчанию через тунели

ip route 0.0.0.0 0.0.0.0 Tunnel1002 10.2.2.5 track 2
ip route 0.0.0.0 0.0.0.0 Tunnel1003 10.2.3.5 track 3
ip route 0.0.0.0 0.0.0.0 Tunnel1004 10.2.4.5 track 4

Подготовка центрального маршрутизатора

interface Tunnel2

description Office 2
ip address 10.2.2.5 255.255.255.252
keepalive 10 3
tunnel source 10.1.1.1
tunnel destination 10.1.2.2

interface Tunnel1002

description Office 2 Backup
ip address 10.3.2.2 255.255.255.252
keepalive 10 3
tunnel source 10.1.1.1
tunnel destination 10.1.2.3

ip route 192.168.2.0 255.255.255.0 Tunnel2 10.2.2.2

ip route 192.168.2.0 255.255.255.0 Tunnel1002 10.3.2.2


interface Tunnel3

description Office 3
ip address 10.2.3.5 255.255.255.252
keepalive 10 3
tunnel source 10.1.1.1
tunnel destination 10.1.3.2


interface Tunnel1002

description Office 3 Backup
ip address 10.3.3.2 255.255.255.252
keepalive 10 3
tunnel source 10.1.1.1
tunnel destination 10.1.3.3

ip route 192.168.3.0 255.255.255.0 Tunnel3 10.2.3.2

ip route 192.168.3.0 255.255.255.0 Tunnel1003 10.3.3.2

Четвертый офис аналогично второму и третьему

keepalive 10 3 будет следить за состоянием тунеля, и, при необходимости, переведет его в down.
Интерфейс в статическом маршрутие сделаент маршрут неактивным в случае падения интерфейса.

В каждом офисе стоят управляемые коммутаторы, в которых подготовлен порт для резервного маршрутизатора.
В инструкции написано. Привезти, включить, подключить к 23-му порту.

Cisco Systems маршрутизатор

Пожалуйста, оцените и ВЫ эту статью:

Комментариев нет. Снаньте первым!


Ваши отзывы и предложения по работе сайта направляйте на форму обратной связи.

Яндекс.Метрика